Back to overview
Maintenance

Security maintenance

Nov 22 at 07:00am HST  –  Nov 22 at 08:16am HST
Affected services
api.nevika.eu

Resolved
Nov 22 at 08:16am HST

We have successfully deployed a new update that significantly enhances our overall security. Thank you for your patience.

Created
Nov 22 at 07:00am HST

General improvements in character security